# ZIP 204: Zcash P2P Network Protocol

Status: Draft

Owners: Daira-Emma Hopwood, Kris Nuttycombe

Snapshot: a34cfc091434275120ff017c92c3b50d3cef623a

Source date: 2026-10-16T02:56:04+01:00

[Source revision](https://github.com/zcash/zips/commit/a34cfc091434275120ff017c92c3b50d3cef623a)

[Official source](https://zips.z.cash/zip-0204) · [Source file](https://github.com/zcash/zips/blob/a34cfc091434275120ff017c92c3b50d3cef623a/zips/zip-0204.rst) · [Discussion](https://github.com/zcash/zips/issues/352)

## Document parts

[Part 1](https://zip-tools-web.harpocrates.workers.dev/zip/204) · [Part 2](https://zip-tools-web.harpocrates.workers.dev/zip/204?part=2)

Reading part 2 of 2. Follow all parts for the complete proposal.

1. [Information on BCP 14 — "RFC 2119: Key words for use in RFCs to Indicate Requirement Levels" and "RFC 8174: Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words"](https://www.rfc-editor.org/info/bcp14)[↩︎](/zip/204#fnref1)

2. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 3.12: Mainnet and Testnet](protocol/protocol.pdf#networks)[↩︎](/zip/204#fnref2)

3. [ZIP 200: Network Upgrade Mechanism](/zip/200)[↩︎](/zip/204#fnref3)

4. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 3.3: The Block Chain](protocol/protocol.pdf#blockchain)[↩︎](/zip/204#fnref4)

5. [ZIP 239: Relay of Version 5 Transactions](/zip/239)[↩︎](/zip/204#fnref5)

6. [ZIP 200: Network Upgrade Mechanism](/zip/200)[↩︎](/zip/204#fnref6)

7. [ZIP 201: Network Peer Management for Overwinter](/zip/201)[↩︎](/zip/204#fnref7)

8. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 7.1: Transaction Encoding and Consensus](protocol/protocol.pdf#txnencoding)[↩︎](/zip/204#fnref8)

9. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 7.6: Block Encoding](protocol/protocol.pdf#blockencoding)[↩︎](/zip/204#fnref9)

10. [RFC 4291: IP Version 6 Addressing Architecture, Section 2.5.5.2](https://www.rfc-editor.org/rfc/rfc4291.html#section-2.5.5.2)[↩︎](/zip/204#fnref10)

11. [RFC 4291: IP Version 6 Addressing Architecture, Section 2.5.5.2](https://www.rfc-editor.org/rfc/rfc4291.html#section-2.5.5.2)[↩︎](/zip/204#fnref11)

12. [BIP 37: Connection Bloom filtering](https://github.com/bitcoin/bips/blob/master/bip-0037.mediawiki)[↩︎](/zip/204#fnref12)

13. [ZIP 239: Relay of Version 5 Transactions](/zip/239)[↩︎](/zip/204#fnref13)

14. [ZIP 239: Relay of Version 5 Transactions](/zip/239)[↩︎](/zip/204#fnref14)

15. [ZIP 200: Network Upgrade Mechanism](/zip/200)[↩︎](/zip/204#fnref15)

16. [BIP 31: Pong Message](https://github.com/bitcoin/bips/blob/master/bip-0031.mediawiki)[↩︎](/zip/204#fnref16)

17. [zcashd PR 7039: Remove alert handling](https://github.com/zcash/zcash/pull/7039)[↩︎](/zip/204#fnref17)

18. [BIP 155: addrv2 message](https://github.com/bitcoin/bips/blob/master/bip-0155.mediawiki)[↩︎](/zip/204#fnref18)

19. [BIP 155: addrv2 message](https://github.com/bitcoin/bips/blob/master/bip-0155.mediawiki)[↩︎](/zip/204#fnref19)

20. [ZIP 155: addrv2 message](/zip/155)[↩︎](/zip/204#fnref20)

21. [ZIP 155: addrv2 message](/zip/155)[↩︎](/zip/204#fnref21)

22. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 7.5: Block Header Encoding](protocol/protocol.pdf#blockheader)[↩︎](/zip/204#fnref22)

23. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 7.6: Block Encoding](protocol/protocol.pdf#blockencoding)[↩︎](/zip/204#fnref23)

24. [Zcash Protocol Specification, Version 2024.5.1 [NU6]. Section 7.1: Transaction Encoding and Consensus](protocol/protocol.pdf#txnencoding)[↩︎](/zip/204#fnref24)

25. [BIP 37: Connection Bloom filtering](https://github.com/bitcoin/bips/blob/master/bip-0037.mediawiki)[↩︎](/zip/204#fnref25)

26. [BIP 37: Connection Bloom filtering](https://github.com/bitcoin/bips/blob/master/bip-0037.mediawiki)[↩︎](/zip/204#fnref26)

27. [zcashd issue 6292: zcashd does not use headers-first sync](https://github.com/zcash/zcash/issues/6292)[↩︎](/zip/204#fnref27)

28. [ZIP 239: Relay of Version 5 Transactions](/zip/239)[↩︎](/zip/204#fnref28)

29. [zcashd relay fee policy (policy.h)](https://github.com/zcash/zcash/blob/cfcfcd93b06d2ee897f1d24eb62692c9e9e0e66d/src/policy/policy.h#L65-L77)[↩︎](/zip/204#fnref29)

30. [ZIP 239: Relay of Version 5 Transactions](/zip/239)[↩︎](/zip/204#fnref30)

31. [ZIP 201: Network Peer Management for Overwinter](/zip/201)[↩︎](/zip/204#fnref31)

32. [Zcash P2P Protocol TLA+ Specification](https://github.com/oxarbitrage/zcash-p2p-spec)[↩︎](/zip/204#fnref32)

## Citation relationships

Cites: [ZIP 155](https://zip-tools-web.harpocrates.workers.dev/zip/155), [ZIP 200](https://zip-tools-web.harpocrates.workers.dev/zip/200), [ZIP 201](https://zip-tools-web.harpocrates.workers.dev/zip/201), [ZIP 225](https://zip-tools-web.harpocrates.workers.dev/zip/225), [ZIP 239](https://zip-tools-web.harpocrates.workers.dev/zip/239), [ZIP 244](https://zip-tools-web.harpocrates.workers.dev/zip/244)

Cited by: [ZIP 258](https://zip-tools-web.harpocrates.workers.dev/zip/258)