# ZIP 0: ZIP Process

Status: Active

Owners: Jack Grigg, Mark Henderson, Daira-Emma Hopwood, Arya, Marek, Kris Nuttycombe, Sam H. Smith, Sean Bowe, Tal Derei, Dev Ojha

Snapshot: a34cfc091434275120ff017c92c3b50d3cef623a

Source date: 2026-10-16T02:56:04+01:00

[Source revision](https://github.com/zcash/zips/commit/a34cfc091434275120ff017c92c3b50d3cef623a)

[Official source](https://zips.z.cash/zip-0000) · [Source file](https://github.com/zcash/zips/blob/a34cfc091434275120ff017c92c3b50d3cef623a/zips/zip-0000.rst)

## Document parts

[Part 1](https://zip-tools-web.harpocrates.workers.dev/zip/0) · [Part 2](https://zip-tools-web.harpocrates.workers.dev/zip/0?part=2)

Reading part 2 of 2. Follow all parts for the complete proposal.

- Some ZIPs, especially in the Consensus category, may include literal code in the ZIP itself which may not be available under the exact license terms of the ZIP.

- Despite this, not all software licenses would be acceptable for content included in ZIPs.

Why are GPL/AGPL/LGPL-style licenses not included?

- No existing ZIP had used these licenses.

- There is no reason to use such licenses for documentation, and including literal code under these licenses in a ZIP could undesirably affect the distribution terms of the ZIP as a whole.

- If necessary, code under such licenses can be linked for informational purposes, or as long as its incompatibility with the zebra, zcashd, Zallet, and/or Zaino licenses is noted.

<a id="see-also"></a>

## See Also

- [RFC 7282: On Consensus and Humming in the IETF](https://www.rfc-editor.org/rfc/rfc7282.html)

- [Zcash Network Upgrade Pipeline](https://electriccoin.co/blog/the-zcash-network-upgrade-pipeline/)

<a id="acknowledgements"></a>

## Acknowledgements

We thank George Tankersley, Deirdre Connolly, Teor, Aditya Bharadwaj, and Conrado Gouvêa for their past contributions as ZIP Editors.

<a id="references"></a>

## References

---

1. [Information on BCP 14 — "RFC 2119: Key words for use in RFCs to Indicate Requirement Levels" and "RFC 8174: Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words"](https://www.rfc-editor.org/info/bcp14)[↩︎](/zip/0#fnref1)

2. [ZIP 200: Network Upgrade Mechanism](/zip/200)[↩︎](/zip/0#fnref2)

3. [ZIPs git repository](https://github.com/zcash/zips)[↩︎](/zip/0#fnref3)

4. [ZIPs git repository](https://github.com/zcash/zips)[↩︎](/zip/0#fnref4)

5. [reStructuredText documentation](https://docutils.sourceforge.io/rst.html)[↩︎](/zip/0#fnref5)

6. [The Markdown Guide](https://www.markdownguide.org/)[↩︎](/zip/0#fnref6)

7. [ZIPs git repository](https://github.com/zcash/zips)[↩︎](/zip/0#fnref7)

8. [ZIPs git repository](https://github.com/zcash/zips)[↩︎](/zip/0#fnref8)

9. [ZIPs git repository](https://github.com/zcash/zips)[↩︎](/zip/0#fnref9)

10. [Zcash Code of Conduct](https://github.com/zcash/zcash/blob/master/code_of_conduct.md)[↩︎](/zip/0#fnref10)

11. [Zcash Code of Conduct](https://github.com/zcash/zcash/blob/master/code_of_conduct.md)[↩︎](/zip/0#fnref11)

12. [Zcash Code of Conduct](https://github.com/zcash/zcash/blob/master/code_of_conduct.md)[↩︎](/zip/0#fnref12)

13. [reStructuredText documentation](https://docutils.sourceforge.io/rst.html)[↩︎](/zip/0#fnref13)

14. [The Markdown Guide](https://www.markdownguide.org/)[↩︎](/zip/0#fnref14)

15. [LaTeX — a document preparation system](https://www.latex-project.org/)[↩︎](/zip/0#fnref15)

16. [ZIPs git repository](https://github.com/zcash/zips)[↩︎](/zip/0#fnref16)

## Citation relationships

Cites: [ZIP 200](https://zip-tools-web.harpocrates.workers.dev/zip/200)

Cited by: [ZIP 32](https://zip-tools-web.harpocrates.workers.dev/zip/32), [ZIP 207](https://zip-tools-web.harpocrates.workers.dev/zip/207), [ZIP 316](https://zip-tools-web.harpocrates.workers.dev/zip/316)